Inkomende mail werkt soms niet

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Inkomende mail werkt soms niet

      Hallo,


      Ik heb al enige tijd een VPS draaien, echter heb ik nu 2 domeinen die klanten van mij een mail willen sturen maar na x aantal tijd krijgen ze een antwoord:
      (mail ontvangen op de server)

      Source Code

      1. Onderwerp: failure notice
      2. Delivery failure notification at VERZENDER.be
      3. zonnehoeve.be<[email protected]>:
      4. TLS not available: connect failed: error:140770FC:SSL
      5. routines:SSL23_GET_SERVER_HELLO:unknown protocol I'm not going to try again; this message has been in the queue too long.
      6. --- Enclosed is a copy of the message.
      7. <mime-attachment>




      Als ik de logs bekijk zie ik een lijn meerdere keren terugkeren:
      2020-03-09 17:32:44 TLS error on connection from smtp.VERZENDER.be (VERZENDER.be) [91.183.128.***] (SSL_accept): error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol

      Source Code

      1. Mijn server specs:
      2. Centos 7.7.1908
      3. Apache 2.4.41
      4. DirectAdmin 1.60.4
      5. Exim 4.93.0.4
      6. MariaDB 10.4.12
      7. Named 9.11.4
      8. dovecot 2.3.10
      9. pure-ftpd 1.0.49
      10. Php 7.3.15
      11. Php 7.2.28
      12. Php 7.1.33
      13. Php 5.6.40
      Display All



      DirectAdmin & FTP zijn beveiligd met LetsEncrypt
      PhpMyAdmin & mail is beveiligd met SSL via het hoofddomein van de server



      Iemand een idee waar ik zou moeten kijken / zoeken?
      Ik heb al enige config aangepast in de exim maar krijg nog regelmatig de melding te zien.
    • wmdiensten wrote:

      Tegenwoordig heb je voor diverse providers DKIM nodig ook een IPV6 record en hem in je SPF record meenemen.

      Mocht dit niet baten dan kan je altijd nog je smtp route aanpassen in je exim file.

      en kijk ook even op mail-tester.com wat jou score is daar zie je ook een aantal meldingen als het niet goed gaat.

      anders kan je me altijd een prive bericht sturen dan kijken we samen via teamviewer.
      Mail-tester.com:

      Wow! Perfect, verzenden maar

      Score :
      10/10

      alles staat in het groen. 1 item staat in het oranje/geel:
      De List-Unsubscribe header is vereist bij het versturen van massa e-mails, het stelt de gebruiker in staat om zich makkelijk uit te schrijven uit je mailinglijst.
      Je bericht bevat geen List-Unsubscribe header


      de test op Mxtoolbox.com zegt dat alle in orde is ivm mail
    • Een test die altijd mogelijk wat inzicht kan opleveren is simpelweg de foutmelding "TLS not available: connect failed: error:140770FC:SSL" in Ome Goegel gooien. Als ik de eerste twee resultaten mag geloven ligt dit waarschijnlijk aan de verzendkant een andere partij (te oude client die een niet langer ondersteund SSL-protocol (vanwege security) probeert te gebruiken, of andere servers die dit doen?).

      Als dit het geval is dan kun jij dit niet direct oplossen maar kun je enkel de klant verzoeken een modernere mailclient te gebruiken... of ergens iets in de communicatie tussen mailservers aanpassen? Het wordt volgens mij niet aangeraden om de oude protocollen weer retroactief te gaan ondersteunen.

      Zo was in een van de resultaten een smtp daemon gepatched om deze oude protocollen weer te ondersteunen, al ontgaat mij de logica daarvan een beetje:

      The problem is that apparently, some servers try to use SSLv3 to send their emails. This is not a bad thing as it's always much better than clear text. We want to forbid users to authenticate using weak SSLv2/v3 but it's OK for external server to use those.
      Waarom is het wel OK voor externe servers? :P Of misschien gaat het meer over authenticeren versus verzenden, geen idee.

      Misschien inmiddels alweer achterhaald, maar wil wel zeggen dat er ergens in de pijplijn ontzettend oud (of ongeldig, zie hieronder) spul wordt gebruikt?

      EDIT: mogelijk gerelateerd: er was (zeer) recent iets te doen met LetsEncrypt certificaten. Weet niet hoe lang het probleem al speelt?
    • Aaron wrote:

      darkshifty wrote:

      Mogelijk wordt er gebruik gemaakt van een SSL protocol die je server niet ondersteund; "TLS not available"? heb je dit protocol actief staan en is er een certificaat geinstalleerd?
      het te ontvangen domein maakt gebruik van letsencrypt.
      Het gaat niet alleen om het certificaat maar ook je "Cipher Suite" bied je daar ook (ik vermoed) SSL v3 aan? en ondersteund je server dat?