Afbeelding laad niet op website

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Afbeelding laad niet op website

      Hoi allemaal,

      Ik ben sinds dit weekend gedoken in CSS en HTML, om mijn eigen Wordpress thema te maken. Nu gaat dit al erg goed, maar ik krijg het maar niet voor elkaar om de afbeelding op mijn site te krijgen.

      De afbeelding staat als volgt in footer.php

      <div class="footercolumn"><p>Contact</p>
      <a href="https://www.facebook.com/kaartenkalligrafie/"><img scr="http://localhost/wordpress/Afbeeldingen/facebook-drawn-logo.png"></a></div>

      En de class "footercolumn" is gedefinieerd als volgt (in style.css)

      .footercolumn {width: 280px; float: left; margin-right: 30px;margin-top: 30px;}

      Andere afbeeldingen laden wel, maar onder in mijn footer laden de afbeeldingen niet (alleen tekst laad wel). Als ik mijn mijn muis op de localhost (etc.) ga staan, dan krijg ik de afbeelding als voorbeeld te zien. Het pad klopt dus wel..

      Iemand een idee waarom hij het niet doet?

      Groetjes Saskia
    • De afbeelding zal voor jou (na correctie) wel zichtbaar zijn, maar als je dit footer-bestand upload waarbij die hyperlink letterlijk "localhost" bevat dan ziet de rest van de wereld dit uiteraard niet omdat hun "localhost" geen lokale webserver heeft die zo'n afbeelding bevat, laat staan een lokale webserver actief heeft in de meeste gevallen.

      Beter is dus om of de hyperlink relatief te maken of dynamisch op te bouwen met behulp van functies van WordPress zelf. Als dit laatste nu al gebeurt hoef je niets aan te passen uiteraard (behalve de spellingsfout).
    • Ik kan hem inderdaad nu zelf zien, na uren bezig zijn zie je dat dan even over het hoofd. Stom..

      Momenteel ben ik de site lokaal aan het opzetten en dan zal ik later hem op een .nl domein zetten. Hoe kan ik de hyperlink dan het beste verwerken nu ik hem lokaal aan het opzetten ben, zodat ik er straks geen problemen mee heb?

      Als ik de hyperlink relatief maak, zal deze dan straks als ik de site upload ook de afbeeldingen meenemen?
    • Saskia.vd wrote:

      Ik kan hem inderdaad nu zelf zien, na uren bezig zijn zie je dat dan even over het hoofd. Stom..

      Momenteel ben ik de site lokaal aan het opzetten en dan zal ik later hem op een .nl domein zetten. Hoe kan ik de hyperlink dan het beste verwerken nu ik hem lokaal aan het opzetten ben, zodat ik er straks geen problemen mee heb?

      Als ik de hyperlink relatief maak, zal deze dan straks als ik de site upload ook de afbeeldingen meenemen?
      Afhankelijk wat de paden zijn, voor afbeeldingen kan je onderstaande gebruiken:

      PHP Source Code

      1. <?php
      2. // Zonder echo template directory
      3. bloginfo( 'template_directory' );
      4. // Met echo template_directory
      5. get_bloginfo( 'template_directory' );
      Het handigst voor jezelf is even zoeken naar die 2 functies, er zitten namelijk meerdere instellingen in die je ongetwijfeld handig zou vinden.